专业的一站式素材服务站!

Discuz!应用中心安装模板提示版本号不匹配的解决方法

有时候我们从应用中心安装模板,在应用中心里模板作者设定允许我们的程序版本,但是我们安装时却提示版本号不匹配,那这是为什么呢?经过我们分析发现是因为X3和X3.1,X3.2的模板是完全兼容的,很多模板是在X3的时候发布,而且之前的机制里一直是即使版本号不同,用户依然可以强制安装,但是,从X3.1后期开始,官方自己把自己的规矩改了,用户没有办法强制安装了,很多作者也没有在意这点,而且应用中心模板的审核与发布、更新的周期更让作者们苦等。
下面我们以discuz! X3的qing模板安装在X3.2上为例子讲解。
首先说的是错误提示图,如下图所示,官方发布的升级版版本号还是X2.5的,不过这不影响我们演示:

1-151231100042B1

我们打开template/qing(其他模板为其他模板的目录)/discuz_style_qing.xml文件,在里面找到X2.5,
如果错误图提示为什么版本就搜什么版本,通常能搜索到至少两处
修改成自己的版本然后保存,重新在后台,界面,风格设置处安装模板即可。

0
分享到:

 1. 本站实行充值兑换金币,1元=1金币,每日签到可领取1个金币,[我要充值]
 2. 标注免费的资源,登录后即可下载,加入我们VIP会员全站无限下载,[去开通]
 3. 本站正式上线, 推荐到QQ或者微信群免费获得VIP会员资格,详情[点我查看]
 4. 如果您找不到合适的资源,请联系我们,告知您的需求,我们会尽快整理发布。

专业的一站式素材服务站!
广告位招租
没有账号? 忘记密码?

社交账号快速登录

喜欢我嘛?喜欢就按“ctrl+D”收藏我吧!♡